Notifications
Clear all

Função semelhante a SEERRO porém com outra condição.  

  RSS

LucasBortolotti
(@lucasbortolotti)
New Member
Entrou: 2 meses atrás
Posts: 1
24/07/2020 3:18 pm  

Oi povo!
Gostaria de saber se tem uma jeito mais fácil de fazer a seguinte função:

=SE(PROCV(A2;Produtos;5;0)>100;"Limite Excedido";PROCV(A2;Produtos;5;0))

Esse é um exemplo, mas acontece comigo direto situações parecidas, em que se o teste lógico for falso, eu quero que apareça o primeiro argumento do teste lógico, para não ter que copiar ele de novo (nesse caso, tive que copiar a função PROCV de novo).

Seria tipo uma SEERRO, mas o teste lógico não seria se o resultado da função fosse igual a erro, mas igual a outro valor. Alguem conhece algo assim?


ResponderCitar (Quote)
Tags do Tópico
EdsonBR
(@edsonbr)
Membro Moderator
Entrou: 5 anos atrás
Posts: 641
25/07/2020 3:15 am  

Bem vindo ao Planilhando, @LucasBortolotti!

Uma maneira seria usar uma fórmula nomeada. Por exemplo:

  • No Gerenciador de Nomes (CTRL + F3), clique em Novo... e dê um nome a essa fórmula nomeada, digamos var_1.
  • Em Refere-se a, insira
    =PROCV(Planilha1!$A7;produtos;5;0)
  • Agora na fórmula que vc vai usar a "variável", insira-a no lugar da expressão inteira:
    =SE(var_1>100;"Limite Excedido";var_1)

Essa metodologia tem muitas limitações, além de ser bem sensível às referências.

Mas espere!!!

Tem novidade no Excel 365, só que por enquanto só pra quem está inscrito no programa Insider do Office 355 (está em beta ainda): é a nova função LET. Ela faz exatamente isso que vc quer.

Com esta função, as fórmulas no Excel vão deixar de ser enormes por ter que ficar repetindo o mesmo argumento, além de ficarem muito mais rápidas, pois o argumento é calculado apenas uma vez e só o resultado é usado nas mais profundas.

Confesso que fiquei bem entusiasmado com essa nova função e também com as recentes de Matriz Dinâmica que já estão disponíveis há algum tempo (ÚNICO, CLASSIFICAR, etc...).

Confira no anúncio da Microsoft: Microsoft Tech Community - Announcing LET in Excel

Help da nova função: Função LET - Excel do Microsoft 365


ResponderCitar (Quote)
deciog
(@deciog)
Prominent Member
Entrou: 5 anos atrás
Posts: 774
25/07/2020 8:53 am  

LucasBortolotti, Bom Dia.

Você pode usar desta forma

=PROCV(A2;Produtos;5;0)

Em formatação de célula na opção Personalizado colocar este formato

[>100] 0 "Limite Excedido";0

Assim ira informar o valor e a mensagem

Se foi útil, clique na mãozinha Curtir é uma forma de agradecimento

Decio

Marque o tópico como Resolvido se foi solucionado seu problema.
Brasil, São Paulo - SP
Décio Gassi


ResponderCitar (Quote)
luizhcosta
(@luizhcosta)
Reputable Member
Entrou: 6 anos atrás
Posts: 417
30/07/2020 11:11 pm  

Olá,

 

Não diria que seja a solução, mas nos permite brincar com o excel. Veja se atende.

 

https://www.sendspace.com/file/p7kz1p


ResponderCitar (Quote)
Compartilhar: