Notifications
Clear all

Somar com critérios

4 Posts
3 Usuários
3 Reactions
1,348 Visualizações
(@wdiego)
Posts: 7
Active Member
Topic starter
 

Boa tarde, Pessoal

Estou tentando criar uma planilha financeira com algumas informações para acompanhamento de gastos. Preciso criar uma função que apresenta o saldo mensal de determinadas despesas.

Exemplo: Despesas com alimentação ( essa despesas ocorrem em todos os meses e quase todos os dia). Preciso de uma função que monstra o saldo total mensal da despesa mencionada. segue anexo exemplo.

Critério - Data

Critério - Tipo de despesa

Desde já agradeço!

 
Postado : 05/04/2021 2:03 pm
Estevaoba
(@estevaoba)
Posts: 0
Eminent Member
 

As datas na aba Lançamento estão formatadas como texto.

Selecione todo intervalo com dados e na faixa de Dados, clique em Texto para colunas, Avançar duas vezes e marque a opção Datas.

Clique Concluir. Feito isto, cole a fórmula abaixo em C2 e copie para baixo. Ajuste os intervalos para a sua realidade.

Good luck!

=SOMASES(Lançamentos!$C$2:$C$1000;Lançamentos!$B$2:$B$1000;B2;Lançamentos!$A$2:$A$1000;">="&A2;Lançamentos!$A$2:$A$1000;"<="&FIMMÊS(A2;0))
 
Postado : 05/04/2021 9:39 pm
wdiego reacted
Estevaoba
(@estevaoba)
Posts: 0
Eminent Member
 

Vi depois que as funções SOMASES e FIMMÊS podem não estar disponíveis na sua versão de Excel.

Então caso a fórmula acima não funcione, uma possibilidade seria criar colunas auxiliares nas duas abas, por exemplo na coluna K, colando esta fórmula em K2 e copiar para baixo:

=SE(A2="";"";MÊS(A2))

A mesma fórmula na célula K2, na aba Lançamento e na aba Cálculo.

 

E esta fórmula matricial em C2 da aba Cálculo. Por ser matricial, após colar, confirme com Ctrl+Shift+Enter em vez de apenas Enter. Se precisar editar essa fórmula, lembre-se de confirmar com as teclas pressionadas simultaneamente, caso contrário ocorrerá erro. Ao fazer corretamente esse procedimento, você verá chaves { } cercando a fórmula na barra de fórmulas.

=SOMA(SE(Lançamentos!$B$2:$B$1000=B2;SE(Lançamentos!$K$2:$K$1000=K2;Lançamentos!$C$2:$C$1000)))
 
Postado : 05/04/2021 10:23 pm
wdiego reacted
P@tropi
(@ptropi)
Posts: 0
Eminent Member
 

Boa noite

Uma outra opção utilizando a função SOMARPRODUTOS que funciona em qualquer versão do Excel.

[]s

Se a resposta foi útil, clique em curtir na mãozinha.

 
Postado : 06/04/2021 8:59 pm
wdiego reacted