Extrair equação para célula  [Resolvido]

Tudo sobre Gráficos, desde o mais simples até o mais complexo!

Extrair equação para célula

Mensagempor carlosrgs » Seg Dez 30, 2019 11:25 am

Bom dia a todos.

Alguém conhece uma maneira que a cada atualização do gráfico, eu consiga inserir os dados da equação em células, sem precisar ficar digitando a cada atualização?

https://www.youtube.com/watch?v=NsubkHh9BTY

Obrigado!
_______________________________________________________________________________________________
Carlos Santos
* Marque o tópico como Resolvido se foi solucionado seu problema.
Avatar do usuário
carlosrgs
Expert
Expert
 
Mensagens: 761
Registrado em: Qua Abr 15, 2015 1:30 pm
Has thanked: 112 times
Have thanks: 196 times

{ SO_SELECT }

Re: Extrair equação para célula

Mensagempor EdsonBR » Seg Dez 30, 2019 3:34 pm

Boas festas, Carlos!

Lembro-me que já houve uma discussão sobre esse mesmo assunto tempos atrás, no tópico "Função equivalente à equação linha de tendência polinomial". A diferença lá é que a linha de tendência era de segundo grau e no caso do seu vídeo é linear (1º grau, portanto mais simples).
Considerando então os dados do gráfico daquele vídeo, os valores X como sendo os do intervalo A3:A17 e os valores Y como B3:B17, há duas maneiras imediatas de extrair os coeficientes da equação através de fórmulas:
  1. Usando as funções INCLINAÇÃO e INTERCEPÇÃO:
    Código: Selecionar todos
    =INCLINAÇÃO(B3:B17;A3:A17)

    Retorna -3,557...
    Código: Selecionar todos
    =INTERCEPÇÃO(B3:B17;A3:A17)

    Retorna 83,457...
  2. Usando a função PROJ.LIN: (Obs.: PROJ.LIN retornará os 2 valores ao mesmo tempo, portanto combine-a com a função ÍNDICE)
    Código: Selecionar todos
    =ÍNDICE(PROJ.LIN(B3:B17;A3:A17);1)

    Retorna -3,557...
    Código: Selecionar todos
    =ÍNDICE(PROJ.LIN(B3:B17;A3:A17);2)

    Retorna 83,457...
Imagem

For this post the author EdsonBR thanked: 3
Adalberto7 (Sex Jan 03, 2020 4:28 pm) • carlosrgs (Qui Jan 02, 2020 4:18 pm) • rlm (Qui Jan 02, 2020 9:22 am)
Avatar do usuário
EdsonBR
Membro
Membro
 
Mensagens: 682
Registrado em: Qui Nov 05, 2015 11:43 pm
Localização: Joinville, SC
Has thanked: 148 times
Have thanks: 450 times

Re: Extrair equação para célula  [Resolvido]

Mensagempor carlosrgs » Qui Jan 02, 2020 9:20 am

Bom dia.

Obrigado pelo retorno e Ótimo 2020.

Acabei resolvendo o problema com o código abaixo:

Código: Selecionar todos
Private Sub Worksheet_Change(ByVal Target As Range)
   
    If (Not Intersect(Target, Range("H5:Q6")) Is Nothing) Then
    ActiveSheet.ChartObjects("Chart 3").Activate
    ActiveChart.FullSeriesCollection(1).Trendlines(1).Select
    Selection.DisplayEquation = True
    Coe01 = ActiveChart.FullSeriesCollection(1).Trendlines(1).DataLabel.Formula
    Procura = "x"
    Coe01_01 = WorksheetFunction.Find(Procura, Coe01, 1)
    Coe01_01_01 = Left(Coe01, Coe01_01 - 1)
    Coe01_01_01_01 = Replace(Coe01_01_01, "y = ", "")
    Range("Z3").FormulaR1C1 = Coe01_01_01_01 / 1
    Coe01_01_02 = Mid(Coe01, Coe01_01 + 1, 6)
    Range("AA3").FormulaR1C1 = CDbl(Coe01_01_02)
    ActiveCell.Offset(-1, 0).Range("A1").Select
   
    End If
     
End Sub
_______________________________________________________________________________________________
Carlos Santos
* Marque o tópico como Resolvido se foi solucionado seu problema.
Avatar do usuário
carlosrgs
Expert
Expert
 
Mensagens: 761
Registrado em: Qua Abr 15, 2015 1:30 pm
Has thanked: 112 times
Have thanks: 196 times


Voltar para Gráficos

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante