MÉDIASE em células intercaladas  [Resolvido]

Fórmulas básicas e avançadas do Microsoft Excel, Fórmulas Matriciais, Fórmulas combinadas, Funções como PROCV, PROCH, SOMASE, SOMA, SE, etc.
Regras do fórum
Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca verde. Imagem

MÉDIASE em células intercaladas  [Resolvido]

Mensagempor Fulvio » Ter Fev 18, 2020 10:07 am

Tenho uma dúvida, como uso a médiase para células que não estão próximas? Exemplo: quero ver a médiase na célula A1 com a A3 (sendo que a A2 tem valores dos quais eu não quero que entre no cálculo), sendo que o critério deve maior que zero.
Você não está autorizado a ver ou baixar esse anexo.
Fulvio
Membro
Membro
 
Mensagens: 5
Registrado em: Ter Fev 18, 2020 9:54 am
Has thanked: 1 time
Have thanks: 0 time

{ SO_SELECT }

Re: MÉDIASE em células intercaladas

Mensagempor z3020100 » Ter Fev 18, 2020 12:37 pm

Boa tarde Fulvio.

Se entendi bem, tente esta fórmula:
Código: Selecionar todos
=MÉDIASE($A:$A;">0")


Creio que resolverá seu caso.
Guilherme Domingos

Se a mensagem foi util Favor Clicar na mãozinha ao lado de "citar".
Quando necessário, lembre se de marcar o tópico como
[RESOLVIDO].
z3020100
Membro
Membro
 
Mensagens: 174
Registrado em: Seg Abr 06, 2015 1:55 pm
Has thanked: 1 time
Have thanks: 75 times

Re: MÉDIASE em células intercaladas

Mensagempor Fulvio » Ter Fev 18, 2020 1:43 pm

Guilherme, obrigado pela resposta.
Mas, preciso fazer o cálculo de células longe uma da outra, em colunas e linhas diferentes. E não a coluna inteira.
Fulvio
Membro
Membro
 
Mensagens: 5
Registrado em: Ter Fev 18, 2020 9:54 am
Has thanked: 1 time
Have thanks: 0 time

Re: MÉDIASE em células intercaladas

Mensagempor ewshaka » Ter Fev 18, 2020 8:52 pm

Boa noite.
Veja se atende.

Att.
Você não está autorizado a ver ou baixar esse anexo.

For this post the author ewshaka thanked:
Fulvio (Qua Fev 19, 2020 7:55 am)
ewshaka
Membro
Membro
 
Mensagens: 33
Registrado em: Seg Nov 11, 2019 11:30 am
Has thanked: 2 times
Have thanks: 14 times

Re: MÉDIASE em células intercaladas

Mensagempor Estevaoba » Ter Fev 18, 2020 9:17 pm

Em P8:
Código: Selecionar todos
=SEERRO(MÉDIASES($B8:$M8;$B8:$M8;">0";$B$7:$M$7;P$7);0)

Copie para a direita e para baixo.

Good luck!
Estevaoba
Membro
Membro
 
Mensagens: 552
Registrado em: Sex Mar 24, 2017 5:11 pm
Has thanked: 49 times
Have thanks: 256 times

Re: MÉDIASE em células intercaladas

Mensagempor z3020100 » Qua Fev 19, 2020 7:48 am

Desculpe, não tinha visto sua planilha de exemplo.

Neste caso as sugestões dos amigos acima atendem sua necessidade.
Guilherme Domingos

Se a mensagem foi util Favor Clicar na mãozinha ao lado de "citar".
Quando necessário, lembre se de marcar o tópico como
[RESOLVIDO].
z3020100
Membro
Membro
 
Mensagens: 174
Registrado em: Seg Abr 06, 2015 1:55 pm
Has thanked: 1 time
Have thanks: 75 times

Re: MÉDIASE em células intercaladas

Mensagempor Fulvio » Qua Fev 19, 2020 8:00 am

Ewshaka, valeu demais sua ajuda. Estava apertado aqui no trampo. Por favor, você pode me explicar porque usou esta fórmula? O conceito dela...
Editado pela última vez por Adalberto7 em Qua Fev 19, 2020 9:09 am, em um total de 1 vez.
Razão: Não use citação sem necessidade, use o botão responder
Fulvio
Membro
Membro
 
Mensagens: 5
Registrado em: Ter Fev 18, 2020 9:54 am
Has thanked: 1 time
Have thanks: 0 time

Re: MÉDIASE em células intercaladas

Mensagempor Fulvio » Qua Fev 19, 2020 8:02 am

Estevaoba, também deu certo valeu mesmo. Você também pode me explicar o conceito da fórmula?
Porque assim entendo quando devo usar até em outras situações.
Editado pela última vez por Adalberto7 em Qua Fev 19, 2020 9:10 am, em um total de 1 vez.
Razão: Não use citação sem necessidade, use o botão responder
Fulvio
Membro
Membro
 
Mensagens: 5
Registrado em: Ter Fev 18, 2020 9:54 am
Has thanked: 1 time
Have thanks: 0 time

Re: MÉDIASE em células intercaladas

Mensagempor Fulvio » Qua Fev 19, 2020 8:04 am

z3020100

Tranquilo amigo. Eu coloquei depois que você respondeu. Vi que era melhor colocar. Obrigado pela ajuda.
Fulvio
Membro
Membro
 
Mensagens: 5
Registrado em: Ter Fev 18, 2020 9:54 am
Has thanked: 1 time
Have thanks: 0 time

Re: MÉDIASE em células intercaladas

Mensagempor Estevaoba » Sex Fev 21, 2020 9:57 am

Bom dia, Fulvio. Que bom que deu certo.
=SEERRO(MÉDIASES($B8:$M8;$B8:$M8;">0";$B$7:$M$7;P$7);0)
A função MÉDIASES permite usar mais de um critério, desde que os intervalos sejam iguais em número de linhas e colunas, então uso todo o intervalo B:M. No primeiro critério, filtro valores maiores que zero e no segundo, valores referentes ao tempo selecionado, à medida que se copia a fórmula para a direita.
A função SEERRO retorna zero caso houver erro de divisão por zero.

Ab.
Estevaoba
Membro
Membro
 
Mensagens: 552
Registrado em: Sex Mar 24, 2017 5:11 pm
Has thanked: 49 times
Have thanks: 256 times


Voltar para Fórmulas & Funções Microsoft Excel

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 3 visitantes