Usando mês para calcular bimestre-trimestre-semestre

Tem alguma dica para o uso do Excel? Algum atalho especial? Algum macete? Aqui é o lugar para você compartilhar!

Usando mês para calcular bimestre-trimestre-semestre

Mensagempor fernando.fernandes » Sex Jan 23, 2015 3:13 pm

Oi pessoal, me deu vontader de publicar uma fórmula útil, que muita gente só faz com vários SE()s juntos, dá pra fazer com matemática básica.

Aplicações (Supondo valor em A1)
1) Você tem uma data e a partir dela vc quer saber qual o trimestre.
2) Você tem o número de um mês, e quer saber qual o bimestre.

Soluções com SE() (Supondo fórmula em A2)
1) =SE(MÊS(A1)<=3;1;SE(MÊS(A1)<=6;2;SE(MÊS(A1)<=9;3;4)))
2) =SE(A1<=2;1;=SE(A1<=4;2;=SE(A1<=6;3;=SE(A1<=8;4;=SE(A1<=10;5;6)))))

Solução alternativa usando fórmula mais simples:
1) =ARREDONDAR.PARA.CIMA(MÊS(A1)/3)
2) =ARREDONDAR.PARA.CIMA(A1/2)

Segue arquivo com exemplo.
Dúvidas é só gritarem!

FF
Você não está autorizado a ver ou baixar esse anexo.
fernando.fernandes
 

{ SO_SELECT }

Re: Usando mês para calcular bimestre-trimestre-semestre

Mensagempor Patropi » Sex Jan 23, 2015 8:38 pm

Vou dar minha contribuição também:

Outra alternativa, retornando o trimestre de uma data:

Considerando, por exemplo uma data na célula A1 --> 23/01/2015, para retornar o trimestre dessa data, use em outra célula a fórmula:

=INT((MÊS(A1)+2)/3)

[]s
Patropi
 

Re: Usando mês para calcular bimestre-trimestre-semestre

Mensagempor Dudomeniconi » Sex Jun 12, 2015 11:45 am

Patropi escreveu:Vou dar minha contribuição também:

Outra alternativa, retornando o trimestre de uma data:

Considerando, por exemplo uma data na célula A1 --> 23/01/2015, para retornar o trimestre dessa data, use em outra célula a fórmula:

=INT((MÊS(A1)+2)/3)

[]s


Patropi, bom dia!

E se eu tiver uma planilha com dados referentes a 2 anos, levando em consideração que a data está em A1, como poderia adaptar essa sua formula para ela considerar os seguintes ranges e retorna qual SEMESTRE corresponde?

...Início........Fim...............Semestre
1-mar-13....31-ago-13..........semestre 1
1-set-13.....28-fev-14..........semestre 2
1-mar-14....31-ago-14.........semestre 3
1-set-14.....28-fev-15..........semestre 4

Abs,

Eduardo
Dudomeniconi
 

Re: Usando mês para calcular bimestre-trimestre-semestre

Mensagempor fernando.fernandes » Sex Jun 12, 2015 12:35 pm

Eduardo, essa sua tabela vai sempre possuir somente 2 anos?
A verificação do semestre conforme as suas regras é pela coluna de início ou de fim?

FF
fernando.fernandes
 

Re: Usando mês para calcular bimestre-trimestre-semestre

Mensagempor Dudomeniconi » Qua Jul 08, 2015 10:50 am

Fala Fernando!

Isso mesmo sempre 2 anos, começando a contar pela data de inicio...

Um abraço!

Eduardo
Dudomeniconi
 


Voltar para Dicas & Macetes

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante