PROCV com varios resultados

Tem alguma dica para o uso do Excel? Algum atalho especial? Algum macete? Aqui é o lugar para você compartilhar!

PROCV com varios resultados

Mensagempor leonardojones » Sex Ago 07, 2009 11:37 am

Se aparecer a frase Você não está autorizado a ver ou baixar esse anexo é porque vc ainda não esta registrado no Fórum....Regístre-se....é rápido, prático e, melhor de tudo, GRÁTIS \o/

Essa tbem é uma dica muito útil....
fazer uma fórmula que seja como o PROCV, mas, que retorne todos os resultados....

A fórmula seria essa....
=SE(ÉERROS(MENOR(SE(Range_nomes=nome;LIN(Range_nomes));LIN(INDIRETO("1:"&LINS(Range_nomes))))-1);"";ÍNDICE(dados_retornar;MENOR(SE(Range_nomes=nome;LIN(Range_nomes));LIN(INDIRETO("1:"&LINS(Range_nomes))))-1))


Re-upado (arquivo anterior foi baixado 607 vezes e imagem visualizada 2060 vezes)

leonardojones
 

{ SO_SELECT }

Re: PROCV com varios resultados

Mensagempor nasario » Sex Ago 07, 2009 1:46 pm

Putz,

Já passei mal demais pra fazer isso e ainda num tinha conseguido.

Muito bom, muito bom mesmo essa!

Valews...
nasario
 

Re: PROCV com varios resultados

Mensagempor Bedin » Ter Ago 11, 2009 2:21 pm

Muito boa essa dica!
Bedin
 

Re: PROCV com varios resultados

Mensagempor JSCOPA » Qua Nov 25, 2009 5:59 am

.
"Você não está autorizado a ver ou baixar esse anexo. "
.
Leonardo, ?????
JSCOPA
 

Re: PROCV com varios resultados

Mensagempor JSCOPA » Qua Nov 25, 2009 6:12 am

OK, já entendi ... só depois que loguei é que foi mostrado o print ...
JSCOPA
 

Re: PROCV com varios resultados

Mensagempor pedral » Seg Jan 18, 2010 1:03 pm

Caro Leonardo,

Tentei aplicar sua planilha, mais só está apresentado erro de #REF!, o que pode ser, pois fiz tudo conforme está no Tutorial.

Abraços,

Olindo Pedral
pedral
 

Re: PROCV com varios resultados

Mensagempor leonardojones » Ter Jan 19, 2010 10:31 am

Talvez nao tenha precionado o ctrl+shift+enter no final da formula!!!

Faz assim...seleciona as linhas aonde vc colocou a fórmula (no exemplo da foto é E1:E8) da um clique na barra de fórmulas e preciona ctrl+shift+enter.....se deu certo...a formula vai ficar com entre {} (chaves)
leonardojones
 

Re: PROCV com varios resultados

Mensagempor pedral » Ter Jan 19, 2010 12:07 pm

Leonardo,

Estou anexando o arquivo para você dar uma olhada, pois a formula está matricial.

Atenciosamente,

Olindo Pedral
pedral
 

Re: PROCV com varios resultados

Mensagempor leonardojones » Qua Jan 20, 2010 7:26 am

Ah sim.....
No exemplo q vc postou.....troque na fórmula a parte do ÍNDICE() de 21 para 2

de ÍNDICE(B21:B39;MENOR(SE.............................
por ÍNDICE(B2:B39;MENOR(SE..............................

leonardojones
 

Re: PROCV com varios resultados

Mensagempor Daniel Tavares » Qua Mar 24, 2010 12:48 am

Show de bola mesmo...a uns 2 anos procurei bastante isto..agora que achei vou mexer em alguns BD's por ai..rs

Valeu!
Daniel Tavares
 

Próximo

Voltar para Dicas & Macetes

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante