Página 1 de 21

PROCV com varios resultados

MensagemEnviado: Sex Ago 07, 2009 11:37 am
por leonardojones
Se aparecer a frase Você não está autorizado a ver ou baixar esse anexo é porque vc ainda não esta registrado no Fórum....Regístre-se....é rápido, prático e, melhor de tudo, GRÁTIS \o/

Essa tbem é uma dica muito útil....
fazer uma fórmula que seja como o PROCV, mas, que retorne todos os resultados....

A fórmula seria essa....
=SE(ÉERROS(MENOR(SE(Range_nomes=nome;LIN(Range_nomes));LIN(INDIRETO("1:"&LINS(Range_nomes))))-1);"";ÍNDICE(dados_retornar;MENOR(SE(Range_nomes=nome;LIN(Range_nomes));LIN(INDIRETO("1:"&LINS(Range_nomes))))-1))


Re-upado (arquivo anterior foi baixado 607 vezes e imagem visualizada 2060 vezes)

Re: PROCV com varios resultados

MensagemEnviado: Sex Ago 07, 2009 1:46 pm
por nasario
Putz,

Já passei mal demais pra fazer isso e ainda num tinha conseguido.

Muito bom, muito bom mesmo essa!

Valews...

Re: PROCV com varios resultados

MensagemEnviado: Ter Ago 11, 2009 2:21 pm
por Bedin
Muito boa essa dica!

Re: PROCV com varios resultados

MensagemEnviado: Qua Nov 25, 2009 5:59 am
por JSCOPA
.
"Você não está autorizado a ver ou baixar esse anexo. "
.
Leonardo, ?????

Re: PROCV com varios resultados

MensagemEnviado: Qua Nov 25, 2009 6:12 am
por JSCOPA
OK, já entendi ... só depois que loguei é que foi mostrado o print ...

Re: PROCV com varios resultados

MensagemEnviado: Seg Jan 18, 2010 1:03 pm
por pedral
Caro Leonardo,

Tentei aplicar sua planilha, mais só está apresentado erro de #REF!, o que pode ser, pois fiz tudo conforme está no Tutorial.

Abraços,

Olindo Pedral

Re: PROCV com varios resultados

MensagemEnviado: Ter Jan 19, 2010 10:31 am
por leonardojones
Talvez nao tenha precionado o ctrl+shift+enter no final da formula!!!

Faz assim...seleciona as linhas aonde vc colocou a fórmula (no exemplo da foto é E1:E8) da um clique na barra de fórmulas e preciona ctrl+shift+enter.....se deu certo...a formula vai ficar com entre {} (chaves)

Re: PROCV com varios resultados

MensagemEnviado: Ter Jan 19, 2010 12:07 pm
por pedral
Leonardo,

Estou anexando o arquivo para você dar uma olhada, pois a formula está matricial.

Atenciosamente,

Olindo Pedral

Re: PROCV com varios resultados

MensagemEnviado: Qua Jan 20, 2010 7:26 am
por leonardojones
Ah sim.....
No exemplo q vc postou.....troque na fórmula a parte do ÍNDICE() de 21 para 2

de ÍNDICE(B21:B39;MENOR(SE.............................
por ÍNDICE(B2:B39;MENOR(SE..............................

Re: PROCV com varios resultados

MensagemEnviado: Qua Mar 24, 2010 12:48 am
por Daniel Tavares
Show de bola mesmo...a uns 2 anos procurei bastante isto..agora que achei vou mexer em alguns BD's por ai..rs

Valeu!