buscas com múltiplos critérios e arrays.

Tem alguma dica para o uso do Excel? Algum atalho especial? Algum macete? Aqui é o lugar para você compartilhar!

buscas com múltiplos critérios e arrays.

Mensagempor skulden » Sex Ago 25, 2017 10:47 am

Prezados, bom dia.

Acredito que muitos aqui já precisaram realizar um índice/corresp ou um procv só que os critérios estavam em colunas diferentes e eram múltiplos, certo? Como por ex: eu querer saber quanto um vendedor vendeu em um mês especifico em uma loja especifica que fica em uma cidade especifica. Esse tipo de busca tem que atender diversos critérios e esses critérios estão localizados em colunas diferentes. É comum que criar colunas auxiliares com a concatenação de todos os valores, transformando assim em uma coluna de unique_key para cada item desse banco de dados, porém, não é necessário. É possivel criar um indice/corresp matricial onde a matriz de busca é a concatenação de todas as matrizes de critério e o valor de busca é a concatenação de todos os critérios especificos.

Segue exemplo.


Se ajudar, clica no joinha!
Se a resposta lhe foi útil, clique no joinha!
skulden
Membro
Membro
 
Mensagens: 175
Registrado em: Ter Jul 19, 2016 8:33 pm
Has thanked: 5 times
Have thanks: 58 times

{ SO_SELECT }

Re: buscas com múltiplos critérios e arrays.

Mensagempor carlosrgs » Sex Ago 25, 2017 11:28 am

Bom dia.

Legal Skulden, segue outra opção para o calculo

=SOMARPRODUTO(($A$2:$A$6=B10)*($B$2:$B$6=C10)*($C$2:$C$6=D10)*($D$2:$D$6=E10)*($E$2:$E$6))
_______________________________________________________________________________________________
Abraço!
Carlos Rafael
* Marque o tópico como Resolvido se foi solucionado seu problema.

For this post the author carlosrgs thanked:
skulden (Sex Ago 25, 2017 11:43 am)
Avatar do usuário
carlosrgs
Membro
Membro
 
Mensagens: 736
Registrado em: Qua Abr 15, 2015 1:30 pm
Has thanked: 110 times
Have thanks: 186 times


Voltar para Dicas & Macetes

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante