Valores semelhantes  [Resolvido]

Como pintar uma célula, como formatar uma borda, funções básicas! Se você não sabe em que categoria postar a sua dúvida, escreva aqui que depois nós mudamos o tópico.
Regras do fórum
Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca verde. Imagem

Valores semelhantes

Mensagempor humberto » Qua Fev 06, 2019 3:44 pm

Olá, boa tarde

Estou criando uma planilha que retorna para mim os produtos mais vendidos, insiro o dados bruto e em uma parte da planilha, na outra parte retorna para mim os produtos mais vendidos, só que alguns produtos as quantidades vendidas são iguais, quando eu vou colocar a descrição do produto conforme a quantidade vendida aparece o mesmo material com a mesma quantidade.
Gostaria de saber qual formula eu utilizo para que mesmo que a quantidade seja igual ele retorne a descrição do produto correspondente.
Estou anexando um exemplo para entenderem melhor.

Obrigado.
humberto
Membro
Membro
 
Mensagens: 67
Registrado em: Seg Set 10, 2012 12:29 pm
Has thanked: 10 times
Have thanks: 0 time

{ SO_SELECT }

Re: Valores semelhantes

Mensagempor carlosrgs » Qua Fev 06, 2019 4:00 pm

Boa tarde Humberto

Segue minha contribuição.
Aqui a opção com DESLOC
Código: Selecionar todos
=SEERRO(ÍNDICE(DESLOC($G$4:$G$20;SE(CONT.SE(J$5:J5;J5)=2;CORRESP(J5;$H$4:$H$20;0);0);0);CORRESP(J5;DESLOC($H$4:$H$20;SE(CONT.SE(J$5:J5;J5)=2;CORRESP(J5;$H$4:$H$20;0);0);0);0);1);"")


Se possível quando postar um arquivo utilize os compactadores comuns, como ZIP ou RAR
Consegui abrir pois no meu trabalho utilizamos o 7z hehe
_______________________________________________________________________________________________
Abraço!
Carlos Rafael
* Marque o tópico como Resolvido se foi solucionado seu problema.

For this post the author carlosrgs thanked:
humberto (Qua Fev 06, 2019 4:26 pm)
Avatar do usuário
carlosrgs
Membro
Membro
 
Mensagens: 731
Registrado em: Qua Abr 15, 2015 1:30 pm
Has thanked: 111 times
Have thanks: 187 times

Re: Valores semelhantes

Mensagempor humberto » Qua Fev 06, 2019 4:27 pm

Obrigado Carlos pela ajuda.

Abs.
humberto
Membro
Membro
 
Mensagens: 67
Registrado em: Seg Set 10, 2012 12:29 pm
Has thanked: 10 times
Have thanks: 0 time

Re: Valores semelhantes

Mensagempor humberto » Qui Fev 07, 2019 4:14 pm

Carlos, na formula que me enviou, se tem dois valores iguais retorna para mim o produto referente, mas a partir de dois valores repetido começa a repetir novamente os valores.
Tenho que repetir parte da formula para que não se repita a descrição, e assim por diante tipo 3,4,5,6...?

Obrigado.
humberto
Membro
Membro
 
Mensagens: 67
Registrado em: Seg Set 10, 2012 12:29 pm
Has thanked: 10 times
Have thanks: 0 time

Re: Valores semelhantes  [Resolvido]

Mensagempor Estevaoba » Dom Fev 10, 2019 12:02 pm

=SE(J5="";"";ÍNDICE($G$4:$G$20;MENOR(SE($H$4:$H$20=J5;LIN($H$4:$H$20)-3);CONT.SE(J$5:J5;J5))))
Fórmula matricial. Cole e confirme pressionando ctrl, shift e Enter simultaneamente.

Good luck!
Estevaoba
Membro
Membro
 
Mensagens: 542
Registrado em: Sex Mar 24, 2017 5:11 pm
Has thanked: 49 times
Have thanks: 247 times


Voltar para Excel - O básico

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 9 visitantes