Fórmula Hora

Fórum para assuntos relacionados as funções de tempo do Excel, como AGORA, DATADIF, DATAM, DIATRABALHOTOTAL, etc...

Fórmula Hora

Mensagempor EdmaraRC » Sáb Mai 23, 2020 1:23 am

Boa noite, galera.

Preciso de ajuda para cálculo de horas (podendo ser em minutos).
Eu estou com 3 mil dados de hora. Possuo uma coluna com o horário inicial e uma com horário final, e preciso do cálculo total de tempo. Alguém tem uma fórmula para isso? Por exemplo, minha hora inicial é 14:00 horas do dia 22/05 e a hora final é 03:00 do dia 23/05.

Vocês conseguiriam me ajudar?

Desde já, muito obrigada.
EdmaraRC
Membro
Membro
 
Mensagens: 1
Registrado em: Sáb Mai 23, 2020 1:19 am
Has thanked: 0 time
Have thanks: 0 time

{ SO_SELECT }

Re: Fórmula Hora

Mensagempor luizhcosta » Sáb Mai 23, 2020 2:16 am

Olá,

Você vai encontrar diversas formas de solução para seu problema. A minha sugestão é que, supondo que o horário inicial esteja na célula A1, e o horário final esteja na célula B1, insira a fórmula a seguir na célula C1.

Código: Selecionar todos
=SE(B1>A1;B1-A1;TEMPO(23;59;59)-A1+TEMPO(0;0;1))+B1

Boa sorte.
luizhcosta
Membro
Membro
 
Mensagens: 465
Registrado em: Seg Dez 08, 2014 4:36 pm
Has thanked: 28 times
Have thanks: 70 times

Re: Fórmula Hora

Mensagempor Adalberto7 » Sáb Mai 23, 2020 11:16 am

Bom dia Edmara

Seja bem-vinda ao fórum!

Movi teu tópico para a sala correta que é Datas & Horas.

Para facilitar anexe um arquivo Excel, com poucos dados, digitando o resultado esperado.

[]s

Adalberto - Moderador
Antigo Patropi
Se foi útil, clique na mãozinha
Avatar do usuário
Adalberto7
Ninja do Excel
Ninja do Excel
 
Mensagens: 266
Registrado em: Qua Jun 19, 2019 9:33 pm
Has thanked: 27 times
Have thanks: 78 times

Re: Fórmula Hora

Mensagempor JSCOPA10 » Sáb Mai 23, 2020 11:30 am

.
Outra sugestão ... =SE(B1<A1;B1+1;B1)-A1 !!! ... Formata hora para 37:30:55 !!! .... Se nenhuma das sugestões funcionar, posta um arquivo exemplo !!!!
.
Avatar do usuário
JSCOPA10
Ninja do Excel
Ninja do Excel
 
Mensagens: 422
Registrado em: Qua Jun 19, 2019 9:11 pm
Has thanked: 41 times
Have thanks: 146 times


Voltar para Datas & Horas

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 0 visitantes