Notifications
Clear all

Não consigo somar os valores importados do M. Acess  

  RSS

Eron
 Eron
(@eron)
Admin Admin
Entrou: 12 anos atrás
Posts: 101
06/07/2009 7:29 pm  

Importei uma tabela do Access pra uma planilha do Excel e gostaria de somar os valores de uma coluna, só que a fórmula =SOMA(A1:A30) está retornando valor 0 sendo que há valores maiores que 0 nas linhas.

O que devo fazer pra obter a soma dos valores?


Resposta:

Quando você importa dados do access ou de outros bancos de dados os campos vem formatados como texto e normalmente o excel não aceita a mudança. uma solução é:

1 - se o dado está na célula a1, na célula(b1) inserir a função =valor(a1).

2 - Copiar a a função para todas as células que contenham os dados.

3 - selecionar toda a coluna B.

4 - copiar, colar especial, valores OK.

5 - deletar a coluna A.

Eron
CRA/RS 27.563
Administrador Fórum Planilhando


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
19/07/2009 9:38 am  

Eu costumo multiplicar o valor da célula por 1.

Escrevo o número 1 em uma célula qualquer, copio, seleciono os dados que estão como texto, com o botão direito do mouse escolho colar especial valores, marco valores, marco também multiplicação e OK.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
29/11/2009 8:59 pm  

Poder ser feito também assim:
=SOMARPRODUTO(VALOR(A1:A30)) ou =SOMARPRODUTO(1*(A1:A30)).
A vantagem é que realiza as sugestões do Eron ou do White diretamente na célula de resumo, sem a necessidade de operações intermediárias.
[ ]s

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: