Relatórios automáti...
 
Compartilhar:
Notifications
Clear all

Relatórios automáticos - Procv


Douglamm
Posts: 6
Registered
Topic starter
(@douglamm)
Ativo
Entrou: 5 anos atrás

Pessoal, bom dia!  Estou precisando da ajuda de vocês.  Eu tenho uma tabela na aba 1 e gostaria que quando eu filtrasse esta por data, fossem linkados os dados dessa tabela nos campos das abas correspondentes por CNPJ, para assim facilitar na geração de Relatórios. Anexei o arquivo. Tentei utilizar o procv duplo porém não consegui. Agradeço desde já.

Responder
1 Reply
Estevaoba
Posts: 502
Registered
(@estevaoba)
Honorable Member
Entrou: 5 anos atrás

No Excel 365 ou posterior. Em C9 e arrastar até C16:

=PROCX($D$4&$G$2; Planilha1!$C$1: $C$31&Planilha1!$A$1: $A$31; PROCX(A9; Planilha1!$A$1: $AN$1; Planilha1!$A$1: $AN$31;""))

Para os outros campos, ajuste $D$4 e A9 para as novas células correspondentes.

Se ocorrer erro #VALOR, verifique inconsistências entre cabeçalhos. Um espaço a mais, um acento, etc.

Por exemplo, "Massa Específica à 20°C" nem sempre está com essa crase.

Good luck!

Responder
Compartilhar: