Notifications
Clear all

Formatar número par ou ímpar, mediante critério


Solan
Posts: 6
Registered
Topic starter
(@solan)
Active Member
Entrou: 3 anos atrás

Boa tarde, uso essa fórmula para formatar número par/impar =MOD(B3;2)=0. Tenho uma tabela B3:R14, com pares e ímpares. Como alterar essa fórmula usando o seguinte critério: Se H2="x", formata pares. Se for "y", formata ímpares

Grato

Responder
4 Respostas
DJunqueira
Posts: 96
Registered
(@dmorais)
Trusted Member
Entrou: 3 meses atrás

Use ÉPAR() ou ÉIMPAR()

=SE(ÉPAR(A1);formata par; formata impar)

Responder
Solan
Posts: 6
Registered
Topic starter
(@solan)
Active Member
Entrou: 3 anos atrás

Tenho uma lista com vários valores(par/impar) e preciso informar um critério fora da lista para formatar dentro dessa lista. Com a fórmula sugerida não consegui formatar todos os valores par ou ímpar.

Exemplo do que preciso:

A1:F10, tem valores para/impar. O valor de J2 é o critério. Se "x", formata só os pares de A1:F10 e se for "y"...

Favor desconsiderar a msg anterior

Responder
DJunqueira
Posts: 96
Registered
(@dmorais)
Trusted Member
Entrou: 3 meses atrás

Se vc tivesse produzido um exemplo desde o início já teríamos resolvido a questão.

Vamos ver se agora vai.

Responder
Solan
Posts: 6
Registered
Topic starter
(@solan)
Active Member
Entrou: 3 anos atrás

A solução proposta tá corretíssima, só preciso incorporar o parâmetro, ou seja se em J2, o valor for um "x" vai formatar par, e se for "y" formata os impares, dentro do intervalo informado. No momento não tenho como anexar uma plan. Grato

 

 

 

Responder