Notifications
Clear all

Ajuste dinamico de saldo


dquirinos
Posts: 1
Registered
Topic starter
(@dquirinos)
New Member
Entrou: 1 ano atrás

Pessoal boa tarde!

Seguinte fiz uma planilha onde eu lanço minhas movimentações de compra e venda de ações.

 

Como em toda planilha minha eu gosto de ter a liberdade de usar filtros e classificações sem risco de prejudicar certas fórmulas.

No caso existem duas coisas primordiais que preciso resultar desta planilha:
1 - minha posição atual em qtd de ações por cada ticker - esta ja está ok!
2 -  meu preço médio de aquisição atual - aqui mora o problema rs.

Bem como podem ver na foto anexa, eu consegui somar o saldo atualizando ele para cada ticker e de acordo com as datas. O problema é que em situações de venda minha formula esta considerando resultado negativo ou positivo quando vendo num valor diferente do meu preço medio atual. o problema deste raciocínio é que de certa forma minha fórmula esta computando lucro ou prejuizo da operação mas não é bem o que preciso aqui.

Como podem ver na foto eu fiz varias compras ABEV3 que totalizaram 15 minha posição final, depois vendi as 15 ações só que com valor a maior do prç médio de compra. isso fez com que no preço médio ficasse um saldo negativo (que na verdade é o lucro) só que o ideal seria ficar com preço medio 0 ja que minha posição agora é 0 > 15-15=0.

Dai as compras seguintes desta data deveriam entender que daquele saldo a frente o valor inicial é 0 e não -34.

segue a formula que fiz até o momento: =SOMASES($K$B;"<="&VALOR($B3))

 

ps: lembrando que o x da questão é que não quero deixar de poder classificar a tabela e são lançados aleatoriamente datas e tickers de negociação. 

Responder
Tags do Tópico