Notifications
Clear all

Busca Avançada


luizfsf
(@luizfsf)
New Member Registered
Entrou: 2 meses atrás
Posts: 1
Topic starter  

Pessoal, tudo bem?
Sou novo no assunto e gostaria de uma ajuda de vocês.
Eu estou com uma plnilha em que consta CNPJ de empresas e informações de upload mensal, eu gostaria de saber se tem alguma formula para eu saber se a empresa entregou o upload mensal dos ultimos 3 meses?


ResponderCitar (Quote)
Estevaoba
(@estevaoba)
Reputable Member Registered
Entrou: 4 anos atrás
Posts: 446
 

Experimente em E2 e copie para baixo:

Good luck!

=SE(SOMA(SE(CONT.SES($A$2:$A$2860;A2;$C$2:$C$2860;$C$2;$D$2:$D$2860;">="&DATA(ANO(HOJE());MÊS(HOJE());1);$D$2:$D$2860;"<="&FIMMÊS(DATA(ANO(HOJE());MÊS(HOJE());1);0));1;0);SE(CONT.SES($A$2:$A$2860;A2;$C$2:$C$2860;$C$2;$D$2:$D$2860;">="&DATA(ANO(HOJE());MÊS(HOJE())-1;1);$D$2:$D$2860;"<="&FIMMÊS(DATA(ANO(HOJE());MÊS(HOJE());1);-1));1;0);SE(CONT.SES($A$2:$A$2860;A2;$C$2:$C$2860;$C$2;$D$2:$D$2860;">="&DATA(ANO(HOJE());MÊS(HOJE())-2;1);$D$2:$D$2860;"<="&FIMMÊS(DATA(ANO(HOJE());MÊS(HOJE());1);-2));1;0))=3;"OK";"")

ResponderCitar (Quote)
EdsonBR
(@edsonbr)
Prominent Member Moderator
Entrou: 5 anos atrás
Posts: 779
 

Bom dia, colegas!

 
Postado por: @luizfsf

...ultimos 3 meses.

 Qual a interpretação que vc dá a "últimos 3 meses", @luizfsf? É relativo ao dia primeiro do mês atual ou ao dia de hoje mesmo.

Por exemplo, se for relativo ao dia de hoje (26/02/21), últimos três meses seria à partir de 26/11/20 (inclusive), enquanto que se for relativo ao início do mês, seria partindo do dia 01/11/20.

Se for relativo ao dia de hoje, teste a fórmula em E2 depois arraste:

=SE(SOMARPRODUTO(($A$2:$A$2860=A2)*($C$2:$C$2860="Entregue no Prazo Upload")*($D$2:$D$2860>=DATAM(HOJE();-3)))=CONT.SE($A$2:$A$2860;A2);"OK";"-")

Já se for relativo ao dia primeiro do mês vigente, teste com essa:

=SE(SOMARPRODUTO(($A$2:$A$2860=A2)*($C$2:$C$2860="Entregue no Prazo Upload")*($D$2:$D$2860>=(FIMMÊS(HOJE();-4)+1)))=CONT.SE($A$2:$A$2860;A2);"OK";"-")

 

 


ResponderCitar (Quote)