Notifications
Clear all

Contagem de sequências de Números.


Felipe Ecks
Posts: 45
Registered
Topic starter
(@ecks)
Eminent Member
Entrou: 4 anos atrás

Bom dia, mais uma vez recorro à ajuda de vocês.
Estou tentando criar uma planilha para contar quantidade de sequências de notas, por exemplo, no modelo de planilha anexo, irei receber números de notas que estarão organizadas em ordem crescente e podem ou não estar em sequencia.
A formula seria para contar a quantidade que essas sequencias acontecem.

Na planilha anexo os números das notas estão organizadas na linha 2, no range B2:U2, na célula W2 eu coloquei o total manualmente, das sequencias de 2 notas, que por sinal se repetem 5 vezes, a sequencia de 3 notas na coluna X linha 2 que se repetem 3 vezes.
Como a planilha é para 1 ano, preciso de algo que me atenda automaticamente todos os dias. Espero que tenha ficado bem explicado.
Como sempre, continuo tentando desenvolver algo aqui, caso consiga, postarei a solução para que sirva de didática.

Desde já agradeço a ajuda.

Responder
3 Respostas
Estevaoba
Posts: 482
Registered
(@estevaoba)
Reputable Member
Entrou: 5 anos atrás

Tente em W2 e copie para a direita e para baixo:

=SOMARPRODUTO(--( FREQÜÊNCIA( SE( SE( ABS( $B2: $T2-$C2: $U2) =1;1;0) =1;COL( $B2: $T2) );SE( SE( ABS( $B2: $T2-$C2: $U2) =1;1;0) <>1;COL( $B2: $T2) ) )=COL( A$1)))

Responder
1 Responder
Felipe Ecks
Registered
(@ecks)
Entrou: 4 anos atrás

Eminent Member
Posts: 45

@estevaoba Cara funcionou perfeitamente, agradeço.

Responder
Estevaoba
Posts: 482
Registered
(@estevaoba)
Reputable Member
Entrou: 5 anos atrás

De nada amigo. Que bom que deu certo.

Tenha um dia abençoado!

Responder