Notifications
Clear all

Extrair Mês e Ano Exclusivos


pedrobb
Posts: 27
Registered
Topic starter
(@pedrobb)
Eminent Member
Entrou: 3 anos atrás

Pessoal,

Na Planilha2, coluna D, quero Mês e Ano Exclusivos, através de fórmulas (igual na Coluna B, feito por VBA, com o uso de Coluna auxiliar.) As Datas Completas estão na Coluna A, da Planilha1.

Se possível, sem coluna auxiliar.

Grato,

Pedro

Responder
Tags do Tópico
6 Respostas
deciog
Posts: 852
Registered
(@deciog)
Prominent Member
Entrou: 6 anos atrás

pedrobb, Bom Dia.

Na célula D3 coloca esta formula lembra versão 2019 acima

=ÚNICO(SE('Dados Extrato'!$A$6:$A$400="";"";TEXTO('Dados Extrato'!$A$6:$A$400;"mm")&"/"&TEXTO('Dados Extrato'!$A$6:$A$400;"aaaa")))

Confere se é desta forma que desejas

Se foi útil, clique na mãozinha Curtir é a forma de agradecimento

Decio

Responder
1 Responder
pedrobb
Registered
(@pedrobb)
Entrou: 3 anos atrás

Eminent Member
Posts: 27

@deciog O meu Office é 2019, não tem a função único.

Responder
Estevaoba
Posts: 482
Registered
(@estevaoba)
Reputable Member
Entrou: 5 anos atrás

Em D3 e copiar para baixo:

=DATA( MÍNIMO( ANO( 'Dados Extrato'!$A$6:$A$344) ); MÊS( MÍNIMO( 'Dados Extrato'!$A$6:$A$344) )+LIN( A1)-1; 1)

 

Good luck!

Responder
1 Responder
pedrobb
Registered
(@pedrobb)
Entrou: 3 anos atrás

Eminent Member
Posts: 27

@estevaoba Grato pela atenção!
Na fórmula matricial acima, tá dando erro #REF quando aumento a linha final para 1000 ('Dados Extrato'!$A$6:$A$1000); Não aceita as datas vazias.
Outra coisa, se faltar um Mês na sequência, vai ficar inconsistente.

Responder
Estevaoba
Posts: 482
Registered
(@estevaoba)
Reputable Member
Entrou: 5 anos atrás

Usando a coluna auxiliar AA, tente esta fórmula matricial.

Cole em D3, confirme com Ctrl+Shift+Enter e copie para baixo:

=SEERRO( ÍNDICE( $AA$4: $AA$1000; CORRESP( 1;( CONT.SE( D$2: D2;$AA$4: $AA$1000 )=0 )*( $AA$4: $AA$1000 <>""); 0) ); "")

Responder
1 Responder
pedrobb
Registered
(@pedrobb)
Entrou: 3 anos atrás

Eminent Member
Posts: 27

@estevaoba Muito obrigado pela fórmula. Tá funcionando. Ocorre que, por ser matricial, deixa o processamento bem lento.
Grato pela atenção!!!!!!!

Responder