Notifications
Clear all

[Resolvido] ÍNDICE / CORRESP procurar próxima célula não vazia, e retornar ela


JSCOPA10
Posts: 225
Moderator
Topic starter
(@jscopa10)
Estimable Member
Entrou: 2 anos atrás

Amigos, boa noite!!

Na tentativa de resolver um problema no trabalho, empaquei ... há 2h tentando roer esse osso, mas não consigo ... por isto jogo a toalha kk!!! ... Alguém pode dar uma luz?? ... Explicações no arquivo anexo!!!

Responder
2 Respostas
EdsonBR
Posts: 853
Moderator
(@edsonbr)
Prominent Member
Entrou: 6 anos atrás
 
Postado por: @jscopa10

...empaquei ... há 2h tentando roer esse osso, mas não consigo...

 

Acontece até nas melhores famílias, amigo @jscopa10... hehehe

Na célula D3, tente essa matricial:

=ÍNDICE($B$3:$B$32;CORRESP(1;($A$3:$A$32=A3)*($B$3:$B$32<>"");0);1)

Mutatis mutandis, a da E3 ficaria então:

=ÍNDICE($C$3:$C$32;CORRESP(1;($A$3:$A$32=A3)*($C$3:$C$32<>"");0);1)
Responder
1 Responder
JSCOPA10
Moderator
(@jscopa10)
Entrou: 2 anos atrás

Estimable Member
Posts: 225

@edsonbr, meu amigo, me salvou!!! ... MUITO OBRIGADO!!! ... SHOW!!!!

Responder