Notifications
Clear all

Mover o Maior


MEDALHA
(@medalha)
Active Member Registered
Entrou: 2 anos atrás
Posts: 8
Topic starter  

Boa tarde a todos, na planilha (Endereços formulas) em anexo; preciso que seja visualizado na aba XIII-End somente o numero maior que repete cada endereço, sendo o numero maior e o endereço correspondente e, também eliminar os "-" do restante das células dos endereços que não foram encontrados.

Que só me traga exemplo:

13 Endereco 1 - Cidade 1

8 Endereco 2 - Cidade 2

4 Endereco 3 - Cidade 3

https://www.sendspace.com/file/790h21

 

 


ResponderCitar (Quote)
EdsonBR
(@edsonbr)
Prominent Member Moderator
Entrou: 5 anos atrás
Posts: 779
 

Não entendi direito, @medalha

No seu exemplo, vc quer puxar o endereço concatenado da última linha cuja coluna "Seção" seja a que está na célula A2 da XIII-End (no caso, 247, que corresponde ao código 5867, Endereço 3 - Cidade 3)?

Não entendi as outras linhas de QTD x Endereço...


ResponderCitar (Quote)
MEDALHA
(@medalha)
Active Member Registered
Entrou: 2 anos atrás
Posts: 8
Topic starter  

Boa tarde

Não, como pode ser observado na aba XXX-End na colula A ha uma contagem (formula) de quantos endereços iguais tem na coluna B, o que preciso, é que traga o total de cada endereço igual da aba XXX, usando a formula que consta na coluna B.

Relação de Endereços por Turma
  247 PAULO FRANCA DOS SANTOS
  QDE Endereço
  13 Endereco 1 - Cidade 1
  8 Endereco 2 - Cidade 2
  4 Endereco 3 - Cidade 3

ResponderCitar (Quote)
Estevaoba
(@estevaoba)
Reputable Member Registered
Entrou: 4 anos atrás
Posts: 446
 

A primeira fórmula matricial (Ctrl+Shift+Enter) em B4 e copie para C4 e para baixo.

A segunda em A4 e copie para baixo.

Good luck!

=SEERRO(ÍNDICE(XIII!C$2:C$759;CORRESP(1;(CONT.SE(B$3:B3;XIII!C$2:C$759)=0)*(XIII!C$2:C$759<>"")*(XIII!$B$2:$B$759=$A$2);0));"")

=SE(B4="";"";CONT.SES(XIII!$C$2:$C$759;B4;XIII!$D$2:$D$759;C4))

EdsonBR curtiu
ResponderCitar (Quote)
MEDALHA
(@medalha)
Active Member Registered
Entrou: 2 anos atrás
Posts: 8
Topic starter  

@estevaoba

Boa tarde.

 

Vou testar, muito obrigado


ResponderCitar (Quote)
MEDALHA
(@medalha)
Active Member Registered
Entrou: 2 anos atrás
Posts: 8
Topic starter  

Bom dia 

Se não for pedir muito, poderia explicar as etapas das formulas?


ResponderCitar (Quote)
MEDALHA
(@medalha)
Active Member Registered
Entrou: 2 anos atrás
Posts: 8
Topic starter  

Bom dia.

Testei. Mas ocorreu uma inconsistência, há endereços diferentes na mesma cidade, quando isso ocorre não efetua corretamento os cálculos. Poderia estar revendo as formulas? Anexei a planilha com o ocorrido.


ResponderCitar (Quote)
Estevaoba
(@estevaoba)
Reputable Member Registered
Entrou: 4 anos atrás
Posts: 446
 

Boa noite.

Alterei a fórmula para retornar a cidade, conforme o endereço.

Fórmula matricial (Ctrl+Shift+Enter)

Cole em C4 e copie para baixo:

=SEERRO(ÍNDICE(XIII!D$2:D$759;CORRESP(B4;SE(XIII!$B$2:$B$759=$A$2;XIII!C$2:C$759);0));"")

ResponderCitar (Quote)