Notifications
Clear all

[Resolvido] Ordenar texto horizontal eliminando colunas em branco


Mineiro
Posts: 118
Registered
Topic starter
(@mineiro)
Estimable Member
Entrou: 8 anos atrás

Boa tarde!

Estou com o seguinte problema: a planilha abaixo apresenta colunas em branco.

  1 2 3 4 5 6
Cliente 1 AA   CC      
Cliente 2   BB CC   EE FF
Cliente 3 AA         FF
Cliente 4       DD EE FF

Gostaria que a apresentação eliminasse essas colunas em branco e ficasse da seguinte forma:

  1 2 3 4 5 6
Cliente 1 AA CC        
Cliente 2 BB CC EE FF    
Cliente 3 AA FF        
Cliente 4 DD EE FF      

Se alguém puder ajudar eu agradeço.

 

Responder
5 Respostas
1 Responder
Estevaoba
Registered
(@estevaoba)
Entrou: 5 anos atrás

Reputable Member
Posts: 472

Supondo que Cliente 1 esteja em A2, use esta fórmula em uma célula vazia e copie para baixo.

Somente no Office 365.

Good luck!

=FILTRO(A2H2<>"")
Responder
Mineiro
Posts: 118
Registered
Topic starter
(@mineiro)
Estimable Member
Entrou: 8 anos atrás

Bom dia!

Meu Excel é o 2016.

É possível fazer sem a função "Filtro"?

 

Responder
2 Respostas
JSCOPA10
Moderator
(@jscopa10)
Entrou: 2 anos atrás

Reputable Member
Posts: 320

@mineiro, coloca a formula, se funcionar, é possível !!!!!!!!!!!!!!!!!!!!!!!!

Outra sugestão: da mesma forma que classificamos na vertical, podemos classificar na horizontal !!! ....... Seleciona tudo > classificar personalizado > opções > da esquerda para a direita > escolha a linha > ok ... PRONTO!!!

 

Responder
Estevaoba
Registered
(@estevaoba)
Entrou: 5 anos atrás

Reputable Member
Posts: 472

Uma opção seria esta fórmula matricial. Colar em B9, confirmar com Ctrl+Shift+Enter e copiar para a direita e para baixo.

Como a fórmula conta com pelo menos uma coluna à esquerda, não pode ser usada na coluna A.

Se usar em outra coluna que não seja a B, ajuste o primeiro intervalo da função CONT.SE. 

=SEERRO(ÍNDICE($B2:$H2;CORRESP(1;(CONT.SE($A9$H2<>"");0));"")

 

Responder
Estevaoba
Posts: 472
Registered
(@estevaoba)
Reputable Member
Entrou: 5 anos atrás

@JSCOPA10, favor informar se a fórmula postada no meu penúltimo post está completa.

Pela segunda vez, noto aqui no Planilhando que depois que concluo o post, a fórmula aparece incompleta, mas não sei se é só pra mim isso. Por isso editei de novo pra anexar a planilha, o que era desnecessário.

 

Obrigado.

Responder