Notifications
Clear all

Solução para cálculo do período de graça no INSS  

  RSS
Giovani Sampaio
(@giovani-sampaio)
New Member Registered

Estou com dificuldades de executar uma das etapas para cálculo do Período de Graça do INSS.

Preciso somar de forma acumulativa períodos de tempo, sendo que toda vez que a qualidade de segurado for N os cálculos anteriores precisam ser zerados, ou seja, perdeu a qualidade de segurado zera e começa a recontagem acumulativa.

Segue exemplo abaixo:

Meses Acumulado Qualidade
14 0 N
9 0 S
6 0 S
11 0 N
21 21 S
106 127 S
45 172 S
31 203  

 Preciso automatizar a coluna Acumulado com os resultados que estão aí.

Tentei com os comandos CONT.SE e SOMASE e cheguei perto.

 

ResponderCitar (Quote)
Postado : 18/11/2020 6:09 pm
JSCOPA10
(@jscopa10)
Estimable Member Moderator

@giovani-sampaio, como pedem as regras, e para facilitar e também agilizar a solução, posta um arquivo com esse exemplo, com o arquivo podemos testar fórmulas (e você pode até explicar melhor lá), e com o desenho que você fez, não tem como!!!!!!!!!!!!!!

ResponderCitar (Quote)
Postado : 18/11/2020 11:36 pm
Giovani Sampaio
(@giovani-sampaio)
New Member Registered

@jscopa10

Segue em anexo o arquivo para inserção das fórmulas.

ResponderCitar (Quote)
Postado : 19/11/2020 10:59 am
Estevaoba
(@estevaoba)
Reputable Member Registered

Cole em J4 e copie para baixo:

Good luck!

=SE(K4="N";0;J3+I4)
ResponderCitar (Quote)
Postado : 19/11/2020 8:37 pm
Giovani Sampaio
(@giovani-sampaio)
New Member Registered

@estevaoba

Boa noite!

Funcionou, muito obrigado!!!

ResponderCitar (Quote)
Postado : 19/11/2020 10:43 pm
Estevaoba curtiu