Notifications
Clear all

Somar com critérios


wdiego
Posts: 2
Registered
Topic starter
(@wdiego)
New Member
Entrou: 3 anos atrás

Boa tarde, Pessoal

Estou tentando criar uma planilha financeira com algumas informações para acompanhamento de gastos. Preciso criar uma função que apresenta o saldo mensal de determinadas despesas.

Exemplo: Despesas com alimentação ( essa despesas ocorrem em todos os meses e quase todos os dia). Preciso de uma função que monstra o saldo total mensal da despesa mencionada. segue anexo exemplo.

Critério - Data

Critério - Tipo de despesa

Desde já agradeço!

Responder
Tags do Tópico
3 Respostas
Estevaoba
Posts: 448
Registered
(@estevaoba)
Reputable Member
Entrou: 4 anos atrás

As datas na aba Lançamento estão formatadas como texto.

Selecione todo intervalo com dados e na faixa de Dados, clique em Texto para colunas, Avançar duas vezes e marque a opção Datas.

Clique Concluir. Feito isto, cole a fórmula abaixo em C2 e copie para baixo. Ajuste os intervalos para a sua realidade.

Good luck!

=SOMASES(Lançamentos!$C$2$A$1000;"<="&FIMMÊS(A2;0))
Responder
Estevaoba
Posts: 448
Registered
(@estevaoba)
Reputable Member
Entrou: 4 anos atrás

Vi depois que as funções SOMASES e FIMMÊS podem não estar disponíveis na sua versão de Excel.

Então caso a fórmula acima não funcione, uma possibilidade seria criar colunas auxiliares nas duas abas, por exemplo na coluna K, colando esta fórmula em K2 e copiar para baixo:

=SE(A2="";"";MÊS(A2))

A mesma fórmula na célula K2, na aba Lançamento e na aba Cálculo.

 

E esta fórmula matricial em C2 da aba Cálculo. Por ser matricial, após colar, confirme com Ctrl+Shift+Enter em vez de apenas Enter. Se precisar editar essa fórmula, lembre-se de confirmar com as teclas pressionadas simultaneamente, caso contrário ocorrerá erro. Ao fazer corretamente esse procedimento, você verá chaves { } cercando a fórmula na barra de fórmulas.

=SOMA(SE(Lançamentos!$B$2$C$1000)))
Responder
Adalberto7
Posts: 77
Moderator
(@adalberto7)
Trusted Member
Entrou: 2 anos atrás

Boa noite

Uma outra opção utilizando a função SOMARPRODUTOS que funciona em qualquer versão do Excel.

[]s

Responder