Gráfico plota célul...
 
Notifications
Clear all

Gráfico plota células vazias com fórmulas como "Zero". Qual a melhor solução?

Página 1 / 2

RSene
Posts: 11
Registered
Topic starter
(@rsene)
Active Member
Entrou: 4 anos atrás

Boa noite.

Estou fazendo uma planilha que contém fórmulas e gráficos. As células onde os gráficos buscam os dados possuem fórmulas, e então eu cheguei naquela situação que muitos se deparam, que é: quando as células que possuem fórmulas mostram um resultado vazio, os gráficos plotam esses resultados vazios como "Zero".

Eu estou buscando uma forma de manter os resultados das fórmulas como vazios, e ainda assim o gráfico não plotar nada. Na minha planilha, o "Zero" é uma opção válida, então eu preciso diferenciar entre zero e vazias.

Eu vi algumas pessoas sugerindo como alternativa o uso da função NAO.DISP() no lugar de "", mas para mim não resolve, porque eu tenho outras células com fórmulas em outra parte da planilha que necessitam desses dados para calcular valores. E quando o resultado é "N/D", essas outras células deixam de calcular, mostrando apenas o valor "N/D".

Eu sei que é uma prática postar uma planilha como exemplo, mas como eu creio que minha pergunta é de fácil entendimento, acho que dá pra arriscar iniciar esse post sem um.

 

Ricardo.

Responder
Tags do Tópico
6 Respostas
DJunqueira
Posts: 96
Registered
(@dmorais)
Trusted Member
Entrou: 3 meses atrás

No caso do gráfico a solução é essa mesma, NÃO.DISP(), as outras fórmulas dependentes terão de sofrer alteração p/ lidar com essa resposta.

Responder
1 Responder
RSene
Registered
(@rsene)
Entrou: 4 anos atrás

Active Member
Posts: 11

@dmorais Ah ok. Bom, nesse caso vc teria alguma alternativa pra me passar nessas fórmulas? As contas dessas fórmulas são contas simples de adição (+) ou subtração (-).

Tipo, =A1+B2+C3 ou =SOMA(A1;B2;C3)

Acontece que como algumas dessas células mostram "N/D", a conta não é feita. Então nesse caso, se alguma dessas células mostrar "N/D", eu preciso apenas que a fórmula as reconheça como vazias e as desconsidere, fazendo a soma ou subtração apenas das células restantes que contenham valores.

Responder
DJunqueira
Posts: 96
Registered
(@dmorais)
Trusted Member
Entrou: 3 meses atrás

=1+1+SEERRO(B2;0)

Responder
RSene
Posts: 11
Registered
Topic starter
(@rsene)
Active Member
Entrou: 4 anos atrás

@dmorais

Mas daí eu terei que adicionar essa fórmula em todos os ítens somados, um por um, certo?

Tipo:

 

=SEERRO(A1;0)+SEERRO(B2;0)+SEERRO(C3;0)+SEERRO(D4;0)....

 

Se eu tiver 15 itens somados eu terei que fazer isso pra todos os 15 itens. Correto?

Esta seria a forma mais prática de se fazer?

Responder
DJunqueira
Posts: 96
Registered
(@dmorais)
Trusted Member
Entrou: 3 meses atrás

Sem a planilha p/ eu dar uma olhada os palpites vão ficando cada vez mais imprecisos...

Geralmente vc monta a fórmula e manda correr linhas abaixo..

Responder
Página 1 / 2