Notifications
Clear all

[Resolvido] Somases Com Data

5 Posts
2 Usuários
3 Likes
1,182 Visualizações
(@jalmeida)
Posts: 43
Trusted Member
Topic starter
 

Pessoal, bom dia!

Gostaria de uma ajuda com as funções Somases, com datas em determinado critério.

A idéia é criar uma fórmula (Somases ou outra) onde ela some os dias úteis e os valores de sábado à domingo na data de segunda-feira, as datas que se repetem não podem conter valores e não podem ser excluídas. Consegui desenvolver o raciocínio mas está dando erro porque a fórmula não está somando corretamente.

Anexo o arquivo para melhor compreensão.

Agradeço a colaboração e ajuda.

 
Postado : 23/04/2022 12:29 am
Estevaoba
(@estevaoba)
Posts: 0
Eminent Member
 

Usei esta fórmula em Q3 e arrastada para baixo:

=SEERRO(SE(E(DIA.DA.SEMANA(B3)=2;B3=B4);"";SE(E(DIA.DA.SEMANA(B3)=2;B3<>B4);SOMA(ÍNDICE('Vendas Por Dia (Base)'!$C$3:$C$2000;CORRESP(B3;'Vendas Por Dia (Base)'!$B$3:$B$2000;0)-2):ÍNDICE('Vendas Por Dia (Base)'!$C$3:$C$2000;CORRESP(B3;'Vendas Por Dia (Base)'!$B$3:$B$2000;0)));ÍNDICE('Vendas Por Dia (Base)'!$C$3:$C$2000;CORRESP(B3;'Vendas Por Dia (Base)'!$B$3:$B$2000;0))));"")

Favor conferir no anexo.

Good luck

 
Postado : 24/04/2022 11:44 am
JAlmeida reacted
(@jalmeida)
Posts: 43
Trusted Member
Topic starter
 

@estevaoba, Boa noite!
Agradeço o retorno e apoio. A solução apresentada foi bastante assertiva e muito boa, entretanto, observei que houve duplicidade em um dos dias, como o 22/04 (sexta-feira), por exemplo. Tentei analisar mas não consegui entender o problema. Caso não se importe, pode dar uma avaliada? Estou retornando o anexo com apontamento da duplicidade.
Grato mais uma vez pela ajuda.

 
Postado : 25/04/2022 11:02 pm
Estevaoba
(@estevaoba)
Posts: 0
Eminent Member
 

Boa noite.

Alterei a primeira SE(E para resultar em branco quando houver duplicidade de datas independente do dia de semana e ficou assim:

=SEERRO(SE(B3=B4;"";SE(E(DIA.DA.SEMANA(B3)=2;B3<>B4);SOMA(ÍNDICE('Vendas Por Dia (Base)'!$C$3:$C$2000;CORRESP(B3;'Vendas Por Dia (Base)'!$B$3:$B$2000;0)-2):ÍNDICE('Vendas Por Dia (Base)'!$C$3:$C$2000;CORRESP(B3;'Vendas Por Dia (Base)'!$B$3:$B$2000;0)));ÍNDICE('Vendas Por Dia (Base)'!$C$3:$C$2000;CORRESP(B3;'Vendas Por Dia (Base)'!$B$3:$B$2000;0))));"")

Veja se atende.

 

Ab.

 
Postado : 25/04/2022 11:54 pm
JAlmeida reacted
(@jalmeida)
Posts: 43
Trusted Member
Topic starter
 

@estevaoba, bom dia!
Esse novo ajuste atendeu perfeitamente minha necessidade. Gostaria de agradecer a atenção e apoio na solução deste problema.
Muito obrigado!
Abcs,

 
Postado : 27/04/2022 1:33 am
Estevaoba reacted