Notifications
Clear all

A soma de textos começando com duas letras iguais na col A

7 Posts
3 Usuários
1 Likes
1,430 Visualizações
OrlandoS
(@orlandos)
Posts: 104
Estimable Member
Topic starter
 

Olá, Pessoal!

Gostaria de obter a quantidade de CC nos textos da col A, considerando as condições de cols B e C.

Segue aqui planilha-modelo

PS: Eu devo manter a função SOMARPRODUTO() na fórmula da minha planilha principal.

 

Grato pela atenção!

Orlando Souza

🧐

Este tópico foi modificado 1 ano atrás by OrlandoS

PS: Se a resposta foi útil, clique na "mãozinha positiva" ou em "curtir" na fonte de link informada, agradecendo ao colaborador do código/fórmula. Eu já fiz a minha parte! :]

 
Postado : 29/01/2023 12:31 pm
P@tropi
(@ptropi)
Posts: 170
Estimable Member
 

@orlandos

Experimente usar a função CONT.SES da seguinte forma:

=CONT.SES(B1:B10;1;C1:C10;"OU";A1:A10;"CC"&"?")

Dê retorno.

[]s

Se a resposta foi útil, clique em curtir na mãozinha.

 
Postado : 29/01/2023 1:36 pm
OrlandoS reacted
OrlandoS
(@orlandos)
Posts: 104
Estimable Member
Topic starter
 

Oi, @adalberto7
A sua fórmula não mantém a função somarproduto(), que está presente na minha planilha-principal com outras funções importantes.
Aguardando outra sugestão com aquela função na mesma fórmula. Grato!

PS: Se a resposta foi útil, clique na "mãozinha positiva" ou em "curtir" na fonte de link informada, agradecendo ao colaborador do código/fórmula. Eu já fiz a minha parte! :]

 
Postado : 29/01/2023 4:06 pm
P@tropi
(@ptropi)
Posts: 170
Estimable Member
 

@orlandos

Não entendi?

A minha fórmula resolve a tua dúvida, coloque ela em outra célula. Se quer manter SOMARPRODUTO na célula E1 não tem problema.

Planilha principal? Só tem uma planilha.

[]s

Se a resposta foi útil, clique em curtir na mãozinha.

 
Postado : 29/01/2023 4:38 pm
OrlandoS reacted
OrlandoS
(@orlandos)
Posts: 104
Estimable Member
Topic starter
 

Entendi. Não é possível outra função dentro de SOMARPRODUTO()

Apesar dos vários critérios dessa função na minha planilha-principal (diferente da planilha-modelo que anexei aqui), vou tentar substituí-la pela função sugerida CONT.SES()

Obrigado!

PS: Se a resposta foi útil, clique na "mãozinha positiva" ou em "curtir" na fonte de link informada, agradecendo ao colaborador do código/fórmula. Eu já fiz a minha parte! :]

 
Postado : 30/01/2023 10:01 am
daphne
(@daphne)
Posts: 95
Estimable Member
 

@orlandos É possivel, sim, usar outras funções dentro da SOMARPRODUTO()

Se quiser manter a função SOMARPRDOUTO(), você pode fazer assim:

=SOMARPRODUTO((ESQUERDA(A1:A10;2)="CC")*(B1:B10=1)*(C1:C10="OU"))

 
Postado : 30/01/2023 12:35 pm
OrlandoS reacted
OrlandoS
(@orlandos)
Posts: 104
Estimable Member
Topic starter
 

Postado por: @daphne

@orlandos É possivel, sim, usar outras funções dentro da SOMARPRODUTO()

Se quiser manter a função SOMARPRDOUTO(), você pode fazer assim:

=SOMARPRODUTO((ESQUERDA(A1:A10;2)="CC")*(B1:B10=1)*(C1:C10="OU"))

\o/ Perfeito, @daphne!

Obrigado!

😎

 

PS: Se a resposta foi útil, clique na "mãozinha positiva" ou em "curtir" na fonte de link informada, agradecendo ao colaborador do código/fórmula. Eu já fiz a minha parte! :]

 
Postado : 30/01/2023 10:05 pm